participants cannot post comments

Hi there openlearning. I'm aware that my colleague Kevin O'Gorman currently has a ticket with this issue but we've decided that I will take over talking to you if that's ok? So he will discontinue his ticket.

 

In both openlearning 1.0 courses and openlearning 2.0 courses we are receiving a growing number of complaints from participants that cannot post comments. I've attached what they see. I was able to replicate the issue in both IE and Chrome, but in both cases it was in an "in private" or "incognito" browser. In the normal browser the commenting worked as expected.

 

So here are the steps to replicate.

 

1. Log out of openlearning. (Not sure if this matters, but perhaps go to account setting and make sure you log out all instances just to be sure)

2. Open a private or incognito window.

3. go to https://www.openlearning.com/aisnsw/courses/ddl1/Activities/IntroduceYourself

4. Try desperately to post a comment :)

 

The attached screenshot shows what happens. Note that this error only occurs in private or incognito.

 

 I want to emphasise that this is also happening in openlearning 2.0 and we have had teachers on a range of browsers and operating systems have this issue. We have replicated it in two browsers.

 

We doubt that all of the teachers who have experienced this issue are using private browsers (if only they were - we could simply tell them not to use an in private browser) , but could there be a specific security setting they need to change in their browser in order to post a comment? 

 

As mentioned we are getting quite a stream of complaints and it is a sensitive time of the year for us as schools and teachers rely heavily on us during this time so I hope this information helps you shed light on a possible remedy?

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Tal, thank you for this very detailed explanation, very helpful. Unfortunately, I wasn't able to replicate the issue; I was able to post a comment in a inkognito and "regular" window in the course you provided. In the past we've had cases where browser addons interfered with the platform functioning properly, but that shouldn't be the case in inkognito mode.

    I will pass on the info to our dev team. Could you also give me an example of the OL 2.0 course where this issue occurs? 

    Reply Like
    • Alenka Prezelj I posted my reply below. PS I will find an OL 2.0 course where the issue occurs and get back to you with that shortly.

      Reply Like
    • Alenka Prezelj Hi Alenka in addition to my reply below. Here is an example of a page in OL 2.0 that has this issue for some users:

      https://www.openlearning.com/aisnsw/courses/PoPProgramming/Activities/IntroduceYourself0

       

      Again I used an icognito window and logged in through the AIS website in order to reproduce this issue.

      Reply Like 1
    • Tal Greengard ... and when I go in just as myself through the openlearning website in an incognito window it works. So again I think it may be the integration with our system?

      Reply Like 1
      • Alenka Prezelj
      • Customer Support Team
      • Alenka_Prezelj
      • 2 mths ago
      • Reported - view

      Tal Greengard Thank you, but this course is OL 1.0?

      Reply Like
    • Alenka Prezelj  I'm sorry Alenka as it's taken me a few days to confirm this. It was confusing from our end as we were running two versions of the course. You are right - it would seem the issue is actually restricted to OL 1.0. Is this version still supported? 

      Reply Like
      • Alenka Prezelj
      • Customer Support Team
      • Alenka_Prezelj
      • 2 mths ago
      • Reported - view

      Tal Greengard Hi Tal! We’re doing our best to resolve critical issues in 1.0 as they come up but given that 2.0 has been available for over 2 years, we recommend moving to that version as soon as possible. We don’t expect to support 1.0 much longer but we’ll make an announcement shortly on exactly when support for 1.0 will end.

      Reply Like
    • Alenka Prezelj  Thank you very much Alenka. It's a good suggestion - we'll get onto this.

      Reply Like 1
  • Hi Alenka. That's interesting. I think it might be an issue with the integration of openlearning and our system. The reason I think this is that the testing I did yesterday was when I logged into openlearning through our website (David Collien helped us set that up) rather than log in on the openlearning website. I should have included that info above.

     

    So this morning I just opened an igcognito browser, logged in through the openlearning website, and everything worked. But if users enter the course through the AIS website the problem can happen. 

     

    I guess this would make sense if they had some security setting on their computer that stopped information sharing between our two sites? 

     

    I hope this info helps your developers. I'm afraid it's becoming a rather pressing issue for us as we are getting quite a few complaints. 

    Reply Like 1
      • Alenka Prezelj
      • Customer Support Team
      • Alenka_Prezelj
      • 2 mths ago
      • Reported - view

      Tal Greengard Hi Tal, thank you for this. I have passed on the information to the developers too.

      Reply Like
Like Follow
  • 2 mths agoLast active
  • 10Replies
  • 68Views
  • 2 Following